新网创想网站建设,新征程启航

为企业提供网站建设、域名注册、服务器等服务

【PAT甲级-C++题解】1041BeUnique-创新互联

✍个人博客:https://blog.csdn.net/Newin2020?spm=1011.2415.3001.5343
📚专栏地址:PAT题解集合
📝原题地址:题目详情 - 1041 Be Unique (pintia.cn)
🔑中文翻译:独一无二
📣专栏定位:为想考甲级PAT的小伙伴整理常考算法题解,祝大家都能取得满分!
❤️如果有收获的话,欢迎点赞👍收藏📁,您的支持就是我创作的大动力💪

创新互联公司网站建设由有经验的网站设计师、开发人员和项目经理组成的专业建站团队,负责网站视觉设计、用户体验优化、交互设计和前端开发等方面的工作,以确保网站外观精美、网站制作、成都网站建设易于使用并且具有良好的响应性。
1041 Be Unique

Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1,104]. The first one who bets on a unique number wins. For example, if there are 7 people betting on { 5 31 5 88 67 88 17 }, then the second one who bets on 31 wins.

Input Specification:

Each input file contains one test case. Each case contains a line which begins with a positive integerN(≤105) and then followed byNbets. The numbers are separated by a space.

Output Specification:

For each test case, print the winning number in a line. If there is no winner, printNoneinstead.

Sample Input 1:
7 5 31 5 88 67 88 17
Sample Output 1:
31
Sample Input 2:
5 888 666 666 888 888
Sample Output 2:
None
题意

找出第一个只出现一次的数字。

思路

具体思路如下:

  1. 先将所有元素放入数组a中,并用哈希表c来记录每个元素出现的次数。
  2. 从头往后遍历a中元素,输出第一个在c中查找数值为1的元素,如果不存在则输出None
代码
#includeusing namespace std;

const int N = 100010;
int a[N], c[N];
int n;

int main()
{cin >>n;

    //记录每个数出现的次数
    for (int i = 0; i< n; i++)
    {cin >>a[i];
        c[a[i]]++;
    }

    //找到最左边只出现一次的数字
    for (int i = 0; i< n; i++)
        if (c[a[i]] == 1)
        {cout<< a[i]<< endl;
            return 0;
        }
    puts("None");

    return 0;
}

你是否还在寻找稳定的海外服务器提供商?创新互联www.cdcxhl.cn海外机房具备T级流量清洗系统配攻击溯源,准确流量调度确保服务器高可用性,企业级服务器适合批量采购,新人活动首月15元起,快前往官网查看详情吧


标题名称:【PAT甲级-C++题解】1041BeUnique-创新互联
网站网址:http://www.wjwzjz.com/article/djogci.html
在线咨询
服务热线
服务热线:028-86922220
TOP